Hello, have You experienced issues with surveys lately? It's not adding points to your profile, could you please look into this?

The button still says "take a survey" even though you've just completed one.

66 views
6 comments
1 upvotes
Related Tags
Anonymous Author
The button still says "take a survey" even though you've just completed one.
1 upvotes
Anonymous Author
Same. Also you get through 80% of survey then takes you to a blank page - over and over.
1 upvotes
Anonymous Author
We're on it. Really sorry about this experience.
1 upvotes
Anonymous Author
It seems to be working for me, except for a minor issue with the DaaS survey.  Because there  was a drag and drop portion to rank some options it didn't work on iPhone 11 on latest iOS.  Question 9 was just a plain white screen on iPhone but worked fine on IE Edge on PC with Windows. In regards to completion of a survey and not seeing it as "Completed" - there seems to be a several minute lag, but it usually updated to completed within a few minutes.  Not a big deal to me. My latest suggestion was to always put a created date on polls, questions, surveys etc so we know if it's 12 months old, the person who asked the question probably no longer cares.....  wonder how many people add comments into polls and questions that are 6+ months old?
0 upvotes
Anonymous Author
I'm not sure but I think this happened with me as well more than once. Can't recall which surveys they were, but this happened just recently in the past few days.
0 upvotes
Anonymous Author
I have just checked and i had rewards missing for 5 surveys in past week
0 upvotes